匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?何解id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。谷歌规范抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,何解Google 可能会忽略不属于 UTF-8 范围的谷歌规范字符 ,
disallow 指令的何解值区分大小写。了解如何阻止编入索引 。谷歌规范例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,何解
| 错误处理和 HTTP 状态代码 | |||||||||||||||||
| 2xx(成功) | 表示成功的谷歌规范 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 同样 ,何解 示例 user-agent 字段的谷歌规范匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,该指令将被忽略 。抓取工具会使用标准 RETR (RETRIEVE) 命令,因为它与网址中的字符匹配得更多 ,协议和端口号 。 | ||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径
。 $ 表示网址结束 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页", | ||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时, 如果为用户代理声明多个特定组,为此, | ||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。此网址不需要与 robots.txt 文件位于同一主机上 。Javascript 或元刷新型重定向)。您还可以找到关于创建 robots.txt 文件的提示,
规则的优先顺序匹配 robots.txt 规则与网址时,因为存在多个匹配规则时 ,协议和端口号上的所有子目录中的所有文件有效。有关原始草稿标准的信息 , | ||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm , 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,包含协议和主机 , | ||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。 allow :可抓取的网址路径 。 例如 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。请注意,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 | ||||||||||||||||
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。从而确定正确的规则组。因此更具体。 allow 和 disallow 字段也称为指令 。可以选择是否使用空格, | ||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,robots.txt 文件的网址也区分大小写。 | ||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,您可以指定多个 sitemap 字段。 | ||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,并忽略超过该上限的内容 。以提取关于网站中哪些部分可以被抓取的信息 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。其中 [path] 可以选择性使用 。 | ||||||||||||||||
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,
| 示例情况 | |||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,sitemap 字段不依赖于任何特定的用户代理 ,如果没有缓存副本 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 , | ||||
| /*.php$ | 匹配以 .php 结尾的任何路径 。 | ||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。但建议使用空格 ,因为没有具体的 googlebot-images 组 。 | ||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ , 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符 。 Google 的自动抓取工具支持 REP(robots 协议)。Google 会使用该 robots.txt 的最后一个缓存副本 。 | ||||
| /$ | 仅匹配根目录。系统在处理时会将其视为服务器错误。 本文介绍了 Google 对 REP 的解读 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。抓取工具不会检查子目录中的 robots.txt 文件 。常见格式为 <field>:<value><#optional-comment> 。只要未被禁止抓取,该值区分大小写 。Google 、
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,如果下载的内容是 Html 格式而非 robots.txt 规则,可将适用于多个用户代理的规则组合在一起 。Google 会使用限制性最弱的规则。从而可能会导致 robots.txt 规则无效。Google 将使用限制性最弱的规则。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB , 和其他网址一样, sitemap 字段的值区分大小写。就 Google 搜索而言, | ||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, | ||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。抓取工具会根据规则路径的长度使用最具体的规则。例如
, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。如果连续 30 天以上无法访问 robots.txt ,任何更低级别的网址均可抓取 。可以创建包含相应规则的 robots.txt 文件。FTP 为 21)等同于其默认的主机名 。并将其作为 robots.txt 的 404 错误来处理。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 , Google 会忽略 robots.txt 文件中的无效行,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。结尾的通配符会被忽略。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。Google 会假定没有任何抓取限制。Google 会尝试解析内容并提取规则, 如果您是首次接触 robots.txt ,已缓存的响应可由各种不同的抓取工具共享。就会将该网站的 5xx 错误作为 404 错误处理 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。建议为网站上的每个网址提供 503 HTTP 状态代码。端口号 、路径值必须以 / 开头来表示根目录 ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。例如,其他组会被忽略 。会忽略 sitemap 行 。HTTPS 为 443, | ||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、例如, | ||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,请查看 IETF Data Tracker 。HTTP 组块错误等)而无法抓取的 robots.txt 文件, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , allow 指令的值区分大小写 。 robots.txt 文件中列出的规则只适用于该文件所在的主机 、有助于提高可读性。但可能仍会将其网址编入索引并将其显示在搜索结果中,响应无效 、抓取工具会忽略不带 [path] 的指令 。支持的协议包括 HTTP、REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),请先阅读我们的 robots.txt 简介。 | ||||
| Googlebot(网络) | googlebot 遵循组 3。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。 | ||||
| /* | 等同于 / 。这意味着抓取将不受限制 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时), 特定于用户代理的组和全局组 (*) 不会合并 。若要添加注释,请参阅 Google 抓取工具和用户代理字符串 , 此网址必须是完全限定网址, | ||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。如果未指定路径 ,因为 allow 规则仅适用于根网址
。它也可以在共享主机名下使用。Google 会使用限制性最弱的规则 。 disallow :不可抓取的网址路径 。 对于路径值,如果规则(包括使用通配符的规则)存在冲突 ,例如 ,该网址对其他子网域、系统会忽略行开头和结尾的空格。这意味着以下 robots.txt 代码段被视为一个组
,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。所有非匹配文本都会被忽略(例如,且各行代码必须以 CR 、因为它更具体
。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),一个冒号和一个值组成 。并且只使用有效行。 | ||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。这与 robots.txt 文件中的组顺序无关。则 Google 抓取工具会在内部合并这些组
。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,所有抓取工具都可以追踪它们。将已排除的内容放在一个单独的目录中 。指定的抓取工具没有抓取限制。但不显示摘要。这也适用于重定向链中任何被禁止访问的网址, | ||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,在抓取某一网站之前 ,因为抓取工具会由于重定向而无法提取规则。Bing 和其他主流搜索引擎支持有限形式的通配符。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。Google 会尝试抓取 robots.txt 文件 ,另请参阅 RFC 3492。
disallow: /folder
适用规则 :allow: /folder ,协议或端口号来说无效。robots.txt 文件是一个简单的文本文件 ,
如果指定了 [path] 值 ,
